24th July 2018

Dallas Network Dallas network outage

Our Dallas network is currently experiencing disruption, we are looking into it.

UPDATE @ 16:54 BST - We're still waiting our upstream resolving the issues, it looks like all of their carriers are saturated, both GTT and Telia so we can't prefer one or the other to clear the current issues up.

UPDATE @ 17:39 BST - We believe that everything has been stable for the last 20 minutes. Please let us know if you continue to see issues. We will update this post once we hear about the cause but the initial suggestion has been DDoS attacks saturating as we mentioned previously.

FINAL UPDATE @ 22:13 BST - We have been informed by our upstream that the network issues today were caused by DDoS attacks against a customer of theirs. These DDoS attacks were distributed and complex therefore a simple null route wasn't a solution which prolonged the impact seen. The solution that our upstream is proposing is upgrading the capacity of one of their carriers by a considerable amount to allow their port to not be saturated by future large attacks that are difficult to stop. This upgrade is expected to be completed within 2 weeks from now. It isn't expected that the events of today will repeat within that timeframe as extra precautions have been taken with operational procedures to limit any future impact.