18th October 2018

Dallas Network Dallas network downtime

Our Dallas network is currently offline. The data centre is looking into the issue.

UPDATE @ 11:12 BST - Our network provider has given an ETA of 10 - 15 minutes.

UPDATE @ 11:48 BST - Our Dallas network came partially came back online at 11:42 BST. We're waiting on the remainder being brought online.

UPDATE @ 12:05 BST - Our Dallas network is now fully back online.