3rd December 2016

SEAKVM3 SEAKVM3 offline

We're aware of an issue with SEAKVM3, it's being looked into.

UPDATE @ 12:47pm GMT 0 - We have brought the server back online after power cycling it as it was unresponsive. We're working through starting up VPS's now.

UPDATE @ 13:07 GMT 0 - We can confirm that all VPS's are now back online. We apologise for the inconvenience caused.