8th June 2016

Phoenix Network Issues

Network issues causing connection issues, waiting on reply from data centre.

UPDATE #1: The data centre say one of their carriers is having issues causing, from what we've seen, some UK traffic to have difficulties connecting. They're working on it.

UPDATE #2: Carrier issue has been resolved.