Seattle packet loss Wednesday 28th February 2024 10:46:00


Our Seattle 20Gb/s DDoS protected IPs are currently seeing significant packet loss. We've contacted our upstream to make them aware and are awaiting a response.

Issue appears to have subsided again.

Issue has come back, we're still awaiting a reply from our upstream about a cause.

This appears to have been resolved as of 11:13 UTC.